Author Topic: request "link to your community" is accepted automatically  (Read 3744 times)

CarstenSchulze

  • Newbie
  • *
  • Posts: 8
    • View Profile
Dear admins,

when users ask to link to our league the requests are pending, of course.
But when the day ends, the users' requests are accepted automatically, although I did not accept or deny them.
Also the mailbox shows their requests as unread message which is correct in these cases.

Additonally previous complete free slots with 3 switches available which are not assigned to the automatical accepted links are now shown as "switches available: 1".


Basically I was going to accept the users' requests after they subscribe to our league in our forum in June
in order to keep slots free for users who won't subscribe.



May I kindly ask to have a look at that issue.

Thank you very much in advance
Best regards,
Carsten

sequel

  • Administrator
  • Full Member
  • *****
  • Posts: 222
    • View Profile
    • SimRacingTools
Re: request "link to your community" is accepted automatically
« Reply #1 on: May 15, 2016, 09:44:23 am »
Dear admins,

when users ask to link to our league the requests are pending, of course.
But when the day ends, the users' requests are accepted automatically, although I did not accept or deny them.
Also the mailbox shows their requests as unread message which is correct in these cases.

Additonally previous complete free slots with 3 switches available which are not assigned to the automatical accepted links are now shown as "switches available: 1".


Basically I was going to accept the users' requests after they subscribe to our league in our forum in June
in order to keep slots free for users who won't subscribe.



May I kindly ask to have a look at that issue.

Thank you very much in advance
Best regards,
Carsten
the curious thing is that there is no automaton for changing status to accepted to a request without human action. Anyway now i will make some tests to replicate your issues and fix what's wrong
Tnx for your notification

CarstenSchulze

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: request "link to your community" is accepted automatically
« Reply #2 on: May 18, 2016, 07:47:20 pm »
short update:

Meanwhile "available switches" turn to 0.
3 users asked to link on May 17, but I just checked the account today (May 18).
Their slots (see slots 14, 15 and 15 at league/community "Simracing United") are shown as 0 switches available, although these slots were free and never used before.

Again, all of the incoming requests are accepted automatically.

sequel

  • Administrator
  • Full Member
  • *****
  • Posts: 222
    • View Profile
    • SimRacingTools
Re: request "link to your community" is accepted automatically
« Reply #3 on: May 19, 2016, 09:15:05 am »
short update:

Meanwhile "available switches" turn to 0.
3 users asked to link on May 17, but I just checked the account today (May 18).
Their slots (see slots 14, 15 and 15 at league/community "Simracing United") are shown as 0 switches available, although these slots were free and never used before.

Again, all of the incoming requests are accepted automatically.

all this question sounds weird to me. I have re-analyzed the code and didn't see any automatism to auto confirm the slot assignment and also notjing strange reguard counting of assignments done. However i have raised at 2 the num switch available of each slot alreay assigned for your league and i have inserted new logs to each operation reguarding slot assignement. Please, I ask to you to warn me when you notice a problem regarding the slots so I analyze the problem checking the logs.
tnx in advance

CarstenSchulze

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: request "link to your community" is accepted automatically
« Reply #4 on: May 21, 2016, 12:01:23 pm »
Thank you very much for resetting the available number of switches.

There is new request yesterday which was accepted automatically (May 20) - again "available switches: 1" (slot 20).

Now the new thing:
The user in slot 21 sent his request today and it is already accepted. That means even the "one day pending period" which I reported is gone meanwhile.
I asked my administrator colleagues, none of us accepted the request.

sequel

  • Administrator
  • Full Member
  • *****
  • Posts: 222
    • View Profile
    • SimRacingTools
Re: request "link to your community" is accepted automatically
« Reply #5 on: May 21, 2016, 12:09:53 pm »
Thank you very much for resetting the available number of switches.

There is new request yesterday which was accepted automatically (May 20) - again "available switches: 1" (slot 20).

Now the new thing:
The user in slot 21 sent his request today and it is already accepted. That means even the "one day pending period" which I reported is gone meanwhile.
I asked my administrator colleagues, none of us accepted the request.

through the logs i was able to get the problem and fix it. If you want to know the problem was a query that everytime a league administrator confirmed pending request his automatically (and this was the bug) accepted the pending request of every league setting the available switch values of his slot to all slots.

CarstenSchulze

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: request "link to your community" is accepted automatically
« Reply #6 on: May 22, 2016, 01:22:48 am »
 :)
Great to hear! WELL DONE and thank you very much for your effort!

I think, it is strange nobody else of the league administrators reported about that issue.
One  - I hope - last request regarding that: May I kindly ask you to reset the number of "available switches" again. As you can see probably, they are currently set to 1 and 0, although you reset them  (I think) 2 days ago.

I think, then it is done finally.  :)


sequel

  • Administrator
  • Full Member
  • *****
  • Posts: 222
    • View Profile
    • SimRacingTools
Re: request "link to your community" is accepted automatically
« Reply #7 on: May 22, 2016, 08:48:42 am »
:)
Great to hear! WELL DONE and thank you very much for your effort!

I think, it is strange nobody else of the league administrators reported about that issue.
One  - I hope - last request regarding that: May I kindly ask you to reset the number of "available switches" again. As you can see probably, they are currently set to 1 and 0, although you reset them  (I think) 2 days ago.

I think, then it is done finally.  :)
ouch sorry, my fault  :P, i had accidently set the num switch available istead exec. Now everything is correct.