Author Topic: Problem with SRT after the small rFactor2 Updates  (Read 1625 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
Problem with SRT after the small rFactor2 Updates
« on: June 26, 2018, 01:21:06 am »
Before the small fixes of rFactor 2 everything was going well. No crash or anything. After the small updates my game crashes randomly. After trying many things, i used the Debug Diagnostics tool to see what was the problem. Turns out that it's SRT all the time.Here is a image for what Debug Diagnostics Tool says.

Also here is a link with some CrashDumps

I tried all the things below some game related some SRT related some PC related.
-Reinstalling SRT
-Change used port and replace the dll's and ini.
-Reinstalling the game
-Reinstall all CommonRedist
-Repairing Windows
-Change nVidia drivers (tried with old and with new)
-Reinstall MOBO/Hardware drivers from scratch
-Drop down some Inside rFactor 2 settings (Inside visual settings)
-Run the game borderless,fullscreen,windowed
-Changing g27 usb port
-Reinstalling g27 drivers
-Run the game with not a single thing at the USB ports.
-Change the memory ddr3 slots to the other 2 available at my MOBO
-Change to aggressive threading
-Change other video settings (Sync,AA,Resolution,FXAA)
-Force 32-bit
-Run with Ctrl+F active
-Close the Record replay function
-New Userdata/Settings (Vanilla)
-Clear registry with CCleaner
-Give high priority to game by Task Manager
-Run with commands to launcher (+multiplayer +connect)
-Clear Steam cache and settings
-Run the game with no 3rd Party plugins except SRT
-Close anti-virus and the processes. Close firewall.
-Run MemDiagnosis and HDD via WD Diagnostic tools